Quixel Help Center home page

Quixel Bridge - Unity Plugin | Documentation, Features and Updates

Pinned

Comments

11 comments

  • Junaid

    Thank you, very helpful.

    2
    Comment actions Permalink
  • BigSky

    The most recent version of the unity (2018.3.10f1) plugin 3.0 does not seem to work with the HDRP for mac mojave.  The objects, materials, etc, all come in fine, but the material defaults to pink, and is given the shader name Hidden/Internal/ErrorShader. 

    It is somewhat fixed by converting the shader to a HDRP Lit shader, but by default, it does not.

    0
    Comment actions Permalink
  • Ajwad

    Hi BIGSKY,

    Can you please try updating your HDRP to the latest version available. (You can go to Windows > Package Manager > HD RenderPipeline) to do that. Almost all of the Unity porjects are created with an outdated render pipeline.

    Let me know if it works.

    Best,

    Ajwad

    0
    Comment actions Permalink
  • BigSky

    That seems to have done the trick - thanks Ajwad!

    1
    Comment actions Permalink
  • gaialau

    Does anyone know how to make double side material to work ?

    I tried the standard shader option on Bridge, we cant use the HDpipeline in this old project.

    0
    Comment actions Permalink
  • Sirahi

    Can we modify plugin code?

    0
    Comment actions Permalink
  • Ajwad

    Hi Gaialau currently there is are no built in shaders with double-sided shading support. So I went ahead and modified the Unity's standard and standard specular shader to support it, You can grab these shaders from here. Download and import them into your project then select "Quixel/Standard" shader in your material properties. I modified the shaders that are shipped with Unity 2019.1.8 so they may or may not work with Unity 2018.3. Sorry for the late reply hope this will fix your problem! :)

    The LiveLink falls under MIT license so feel free to modify it as you like. :)

    0
    Comment actions Permalink
  • Sirahi

    I updated megascan bridge yesterday and all my downloaded assets are gone and the bridge is not signing in or downloading any asset! What should I do? :(

    0
    Comment actions Permalink
  • petr0nije

    Hello, i like quixel sooo much and thank you all for the hard work there! I just got few questions.
    Whichever unity I use i get the same error. Please can you tell me what is it all about? I cant's see the all LOD objects.
    And will all this be compatible with newest unity 2019.3? Is there any unity version that this megascans can work properly? many thanks in advance!

    0
    Comment actions Permalink
  • Keith Brown

    When trying to use the exporter in bridge, unity keeps giving me an error that the asset already exists in the project and I should delete/rename the existing folder first.  Has anyone else gotten this error?  I can create a brand new Unity project, import the live line plugin and the very first asset that I import gives me this error.

     

    0
    Comment actions Permalink
  • AndorfTheWhite

    Hi,

    so to be 100% clear on this: Can we use all the library for FREE on Unity?

    Edit: Ok so from what I read on the terms/conditions of use, we can use them for free for testing, but when we want to actually release the product (game) with these Quixel assets, then we need to purchase a subscription?

    0
    Comment actions Permalink

Please sign in to leave a comment.