Quixel Help Center home page

17.5.173 + HtoA 4 - Error and current workarounds (.ENV fixed in 17.5.204+)




  • MagnusL3D

    There is one more issue currently with 17.5.173 and HtoA4, the old workaround for opacity inside the Quixel Arnold HDAs is no longer working in HtoA4, the best solution for the time beeing is that if the object you are sending over does not have a opacity map, just disconnect the opacity connection in the material.

    Comment actions Permalink
  • efxlab

    yes I confirm for env. Now it works. For opacity its right if the opacity is empty it need to break the connection. thanks

    Comment actions Permalink
  • MagnusL3D

    The Houdini.ENV file issue was a bug in Houdini that has been fixed 17.5.204 and above.

    Comment actions Permalink
  • dan_ita

    Houdini 17.5.360 here, still same problem. I have redshift installed, not arnold.  I have tried both ideas with no success (moving the Quixel line before the RS line, the quixel megascan menu disappers from houdini ). Please help!

    Here is the error: 

    Traceback (most recent call last):
    File "E:/Megascan/Megascan Library/support/plugins/houdini/3.4.0/MSLiveLink/scripts/python\MSLiveLink\MS_API.py", line 127, in InitializeImporter
    File "E:/Megascan/Megascan Library/support/plugins/houdini/3.4.0/MSLiveLink/scripts/python\MSLiveLink\MS_Importer.py", line 136, in initAssetImport
    path = self.importGeometryData( self.GeometryList, AssetMaps )
    File "E:/Megascan/Megascan Library/support/plugins/houdini/3.4.0/MSLiveLink/scripts/python\MSLiveLink\MS_Importer.py", line 566, in importGeometryData
    self.separated_items = MS_separator.ms_geometry_separator(self, subnet, meshList, material)
    File "E:/Megascan/Megascan Library/support/plugins/houdini/3.4.0/MSLiveLink/scripts/python\MSLiveLink\MS_separator.py", line 190, in ms_geometry_separator
    separated = create.createNode('geo', item)
    File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.360/houdini/python2.7libs\houpythonportion\ui.py", line 850, in decorator
    return func(*args, **kwargs)
    File "C:/PROGRA~1/SIDEEF~1/HOUDIN~1.360/houdini/python2.7libs\hou.py", line 8568, in createNode
    return _hou.Node_createNode(*args, **kwargs)
    hou.OperationFailed: The attempted operation failed.
    Invalid node name

    EDIT:  It seems to happen only with Mushrooms, and Button Mushrooms, at least among the models I have... Thanks!

    EDIT2:  re-downloaded asset and problem seems fixed. Thanks!

    Comment actions Permalink
  • EricP


    I'm actually having the same issues in the newest version of houdini and arnold ( htoa-5.3.0 and houdini 18.0.499 ) - i didn't found a workaround yet.. is there any soloution ?

    Even if there was a bug in earlier houdini versions, i've tried all the solutions from this post but nothing works. (same results as DAN_ITA when moving the quixel line,  which i've added by myself)

    My environment file by default only has the arnold path :

    # htoa config start
    PATH = "$PATH;C:/Users/Eric/htoa/htoa-5.3.0_r233605f_houdini-18.0.499/htoa-5.3.0_r233605f_houdini-${HOUDINI_VERSION}/scripts/bin"
    HOUDINI_PATH = "C:/Users/Eric/htoa/htoa-5.3.0_r233605f_houdini-18.0.499/htoa-5.3.0_r233605f_houdini-${HOUDINI_VERSION};&"
    # htoa config end





    Got the solution after two days of intensive research, un- and reinstallations of different houdini/htoa versions and lots of frustration haha :)

    To everyone who has the same struggle, check out this fantastic explanation on how to solve houdini environment problems with packages:


    My custom made arnold.json file which solves the problem:

    "env": [
    "PATH": "C:/Users/Eric/htoa/htoa-5.3.0_r233605f_houdini-18.0.499/htoa-5.3.0_r233605f_houdini-18.0.499/scripts/bin",
    "method": "append"
    "path": "C:/Users/Eric/htoa/htoa-5.3.0_r233605f_houdini-18.0.499/htoa-5.3.0_r233605f_houdini-18.0.499"


    Comment actions Permalink

Please sign in to leave a comment.