Quixel Help Center home page

Non manifold geometry

Answered

Comments

10 comments

  • Jin

    Hello! Are you using RenderMan for Maya? If yes, which RenderMan version on which Maya version?

    0
    Comment actions Permalink
  • Gabriel34

    I'm using Arnold 5.4 and maya 2019.2

    0
    Comment actions Permalink
  • Jin

    Our (Megascans) assets are not suited for a sub-division workflow (OpenSubD or Catmull–Clark) subdivision at render time is indeed impossible due to the triangulated topology of all 3D assets. You do not need subD as we provide several LODs (use displacement with them) + a High Poly mesh (no displacement required).

    Could you check them out and let me know if you still require further assistance or explanation?

    Best,
    Jin

    0
    Comment actions Permalink
  • Gabriel34

    Thanks for the answear, I started using the highpoly.

    However I still don't understand how to use the displacement map without subdividing the mesh.

    My guess would be that the displacement map are usefull for game engine but not with a workflow Maya/Arnold.

    Cheers

    0
    Comment actions Permalink
  • Jin

    Hey!
    The displacement is absolute need for 2D surfaces and 3D assets (when using our LODs). The high poly does not require any displacement map as the information is "baked" into the mesh.

    If you use LODs, that's how you enable displacement for our 3D assets:

    Simply plug the displacement map for the LOD mesh (the number means the Level Of Detail: 0 being the highest LOD aka level of detail, and 5 the lowest, so very few poly count) and then click on your mesh and go to the Arnold tab and enable these settings:





    To not be mistaken with classic sub division for quad based topology!

    Let me know if you have any questions.

    Cheers
    Jin

    0
    Comment actions Permalink
  • Gabriel34

    Thanks for your detailed reply.

    I have well read your settings. They are, I think, the same as the Bridge plugin set up automatically.

    This settings are working on most of the assets.

    However if there is non-manifold edge on the mesh, Arnold still don't subdivide the mesh.

    In that case, it still look almost good since the Autobump kick in, but there is no actual displacement. The effect is the most noticable on the outline.

    See example below.

    I'm sorry if I am missing something here. Also I would like to precise, it is not something that happen to me with all the asset but only some of them. 

     

     

    0
    Comment actions Permalink
  • Jin

    Hey Gabriel, this is very interesting if it's only happening with some specific assets. Could you share me their IDs ? I need to try them myself here to investigate! If the mesh has a problem we will fix it ASAP!

    Right click > Copy asset ID


    Waiting for your reply!

    0
    Comment actions Permalink
  • Gabriel34

    Sure, I have found non manifold edges only on: tletbf2fa and tliuddffa (but i didn't test many assets).

    0
    Comment actions Permalink
  • Jin

    I'll investigate these two assets! May I know: FBX or OBJ? Also, which mesh LOD (number) or Highpoly (guessing: it's a LOD as you don't need displacement for High Poly)?

    0
    Comment actions Permalink
  • Jin

    We've investigated the issue. It doesn't happen with all renderers and we will look further into it.

    0
    Comment actions Permalink

Please sign in to leave a comment.