Quixel Help Center home page

How and where to download Quixel Bridge for Linux?




  • joaarn

    Btw, what is the latest linux Quixel Bridge version? 

    I've tried with Bridge2019.5.0.AppImage and Bridge2020.2.3.AppImage with 3.4.0 and 4.4 of MSLivelink and have had various issues when I try to export 3d Megascans assets straight into a Houdini.  It ranges from errors in the .config/Bridge/bridge.log file to "Error connecting to socket at port: 13290" and I've not been able to get the livelink to work. I have Houdini 18.0.463 but I can switch to something different if needed.

    It would be great to explain how the 13290 port communication works or even how to debug it. I'm not sure if that is locked by IT here.





    Comment actions Permalink
  • Jin

    Hello Jaokim,

    Although I don't know how-to, here is the link from the Quixel Bridge Linux page (official). Regarding the MSplugin for Houdini, did you look into the official documentation?


    Comment actions Permalink
  • joaarn

    Hi Jin,

    Thanks for your reply, the link you refer to I don't seem to have permission to access:

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <Message>Access Denied</Message>


    Yes I have tried to follow the online docs and I've tried to look look in .config/Bridge/* files and 4.4/MSLiveLink/scripts/python/MSPlugin subdirectory and in particular the SocketListener.py script where the port error print("Error connecting to socket at port: 13290") comes from. I believe this is the reason why MSLiveLink communication doesn't work.


    This is what I get in the shell when I start up Bridge, maybe the failed to fetch is a clue but the Bridge UI starts up so something works. I can get an asset to import to the Local Library Path, I just can't get it straight into Houdini which seem like a nice feature to have.

    > ./Bridge2020.2.3.AppImage
    Fontconfig warning: "/etc/fonts/fonts.conf", line 86: unknown element "blank"
    {"level":"info","message":"Setting user agent: megascans-bridge","timestamp":"2020-06-15T16:52:03.548Z"}
    {"level":"info","message":"BRIDGE_VERSIONS_FOLDER: https://d3uwib8iif8w1p.cloudfront.net/bridge/plugins_10/","timestamp":"2020-06-15T16:52:05.835Z"}
    {"level":"error","message":"Failed to fetch https://s3-us-west-2.amazonaws.com/quixel-megascans-static/bridge/plugin_versions_10.json","timestamp":"2020-06-15T16:52:06.414Z"}
    {"level":"info","message":"versions file saved ","timestamp":"2020-06-15T16:52:06.731Z"}


    I'm not too familiar with port communication or how this should work but I've checked with netstat and lsof commands for anything megascan(13290) and houdini related.

    > netstat -tunlp | grep 13290
    tcp6 0 0 :::13290 :::* LISTEN 57008/537.36 --node

    > lsof -nP -iTCP -sTCP:LISTEN | grep megascan
    megascans 57008 joakim 47u IPv6 1098051146 0t0 TCP *:13290 (LISTEN)
    megascans 57008 joakim 48u IPv4 1098051147 0t0 TCP (LISTEN)
    megascans 57008 joakim 49u IPv4 1098051148 0t0 TCP (LISTEN)

    > lsof -nP -iTCP | grep houdini
    houdinifx 8608 joakim 82u IPv4 1098009931 0t0 TCP *:38492 (LISTEN)
    houdinifx 8608 joakim 83u IPv4 1097991630 0t0 TCP> (CLOSE_WAIT)
    houdinifx 8608 joakim 84u IPv4 1097978284 0t0 TCP> (CLOSE_WAIT)
    houdinifx 8608 joakim 88u IPv4 1098011990 0t0 TCP> (CLOSE_WAIT)
    houdinifx 8608 joakim 96u IPv4 1098016964 0t0 TCP (LISTEN)



    Any advice where to go next? Any workarounds? Is this a bug?

    I've seen a couple of forum questions similar to this so it would be good to get an update and clarification from Quixel support how this works.


    Let me know if there is anything you want me to test or run on my side.



    Comment actions Permalink
  • Jonathan (Community Manager)

    You should be able to download Bridge on your Linux machine by visiting https://quixel.com/bridge.

    Comment actions Permalink
  • joaarn

    Hi Jonathan,

    That webpage/link looks like it defaults to the OS of the browser. Unfortunately my machine that have access to internet is a Windows box and suggest a Bridge.exe which will not run on a rhel7 machine. Is there some other download page where you can chose which OS the bridge file is?

    For fun I switched the port settings on Bridge UI and SocketListener.py to 38492 which houdini already seems to have open/communicate but I got the same print("Error connecting to socket at port: 38492")


    Is Bridge2020.2.3.AppImage and 4.4/MSLiveLink the latest for linux? 




    Comment actions Permalink
  • joaarn

    Last test to narrow down the issue.

    I can't get passed the socket_.bind((host, self.socketPort)) line in SocketListener.py script. The values looks correct('localhost', '13290') but python throws an exception.





    Comment actions Permalink
  • joaarn

    From my lsof output it looks like Quixel Bridge use IPv6 to communicate over port 13290, is that true?

    Most port communication on my computer including houdini is registered as IPv4. 

    Is the SocketListener.py script written to communicate over IPv6 and/or IPv4? How does this work?



    Comment actions Permalink
  • Ahmad Salman

    Hi joaarn


    This is Ahmad from Quixel Support. 

    For further diagnosis and corresponding troubleshoot, I am converting this post into a support ticket. You will receive a corresponding email accordingly as well. Our support team will reach out to you now on the concerned email thread. 


    Comment actions Permalink

Please sign in to leave a comment.