Quixel Help Center home page

Custom mesh to UE4 from Mixer

Completed

Comments

2 comments

  • Official comment
    Urooj

    Hi Etenard!

    Mixer, currently does not support 3d export. So you can not export a mesh directly into UE4. 

    But in order to export and use the mesh and the maps in UE4, you can:

    • Import the maps and the mesh into Bridge and then use it in UE4.
    • Export the maps directly into your local folder and then import them into UE4.

    Export from Mixer:

    -Export the maps from Mixer through the Export tab by specifying an Export location as highlighted in the image below:

    Note: The File>Export to library button will be greyed out when you are working with a 3d mesh.

    -Once exported, they'll be placed in a folder which you can explore by going in to the same location you had mentioned before.

    Import in Bridge: 

    Before importing in to Bridge, you can keep the mesh and the maps in one folder (for your ease).

    -Go to Bridge>File>Import Asset

    -Select the Folder that has the maps and the mesh in it(As you wont be able to select the maps manually from here therefore you are not able to view the content inside the folder in this stage)

    -Once you are able to view the "Import settings window", you can add/remove maps and add other details, manually according to your choice.
    Also you can add a mesh file from a folder in this step. 

    -Select "Import" 

    Reload the library and the asset will be shown in the Local>Imported section of Bridge. 

    After this step, you can export the asset in to unreal or any other tool through Bridge(Maps along with the mesh).

    And about the manual import of assets into UE4, it won't consist the master material as it is only incorporated in the asset, when exported using the plugin. So this is considered to be the right way to do this.

    But make sure the "import MasterMaterial textures" is checked in the Megascans plugin window in UE4 when you are about to export.

    Hope it was helpful. :)

    Best,
    Urooj

     

    Comment actions Permalink
  • Etenard

    Thank you very much!

    0
    Comment actions Permalink

Post is closed for comments.