Quixel Help Center home page

Quixel Bridge is super slow when exporting assets to Unreal Engine

Completed

Comments

5 comments

  • Official comment
    Ian

    Hello,
    Thanks for taking the time to reach out to us. When exporting from Bridge to Unreal please ensure that Bridge and Unreal are the only programs running. Other memory or processor-heavy programs can result in increased time it takes for Bridge to export.

    Additionally, extra features such as channel packing may also result in increased export times as the image converter needs to process the maps that were downloaded into a channel-packed map for export. Resolution, complexity, and overall file size can also result in slower times.

    While not the most efficient route, for faster exports attempt to download the asset in the same file format and resolution that you plan on using them within the engine. and disable channel-packing. This will bypass the image converter entirely and will result in a quicker export.

    Comment actions Permalink
  • Jonathan (Community Manager)

    Bridge is limited by Unreal's import speed. IIRC, UE can only import using one core. It isn't possible to improve the speed given engine limitations unless you're willing to purchase a more powerful CPU.

    0
    Comment actions Permalink
  • Swastik2004

    I did a complete reinstall of both Unreal Engine and Quixel Bridge, updated to their latest version. And as suggested by Ian, I closed off any other CPU intensive applications. And magically, the export times were reduced to a mere 30 seconds with 4k textures. I found that the Megascans plugin for Unreal Engine was also updated this time. So, what exactly is the reaosn that my export times suddenly increased? Did I install a lower version of the Megascans plugin on UE4 the prevous time? Is that a reason for which the export times were so high the previous time?

    0
    Comment actions Permalink
  • Ian

    Since multiple changes were made at once it's hard to say which one was the most beneficial to your experience. However, I would say the performance increases could arguably be ranked as follows;

    1. Bypassing the ImageMagick converter by downloading and exporting files in the same format and resolution
    2. Closing other CPU and GPU intensive programs. You'll notice that upon Export from Bridge, your CPU is utilized to package and export your selections while your GPU briefly spikes while UE4 is actually importing and setting up the asset. 
    3. We are constantly striving to improve our plugins and functionality so if you've installed an updated plugin - that could also have performance benefits.

    I hope this has been helpful!

    0
    Comment actions Permalink
  • Raúl

    I am still having this problem even in UE5. 
    I have 32gb ram an SSD and an RTX and still too slow. it may take up to 2 min to import one texture or object with nanite enabled. 

    1
    Comment actions Permalink

Please sign in to leave a comment.