Quixel Help Center home page

Unreal Engine 4.25.3: Vertex Blend Material problems

Completed

Comments

17 comments

  • Official comment
    Ian

    Thank you for your patience with regard to the new Material Blend. We understand that some of you are encountering an error while trying to use the new blend material in an existing Unreal Project.

    I can assure you we're already working on a fix to this issue and we aim to ship that resolution as quickly as practicable. However, we know that projects can't always wait and we have a workaround to get you up and running quickly.

    Within Bridge please download the latest plugin. If you're unsure of whether or not you have the latest version you can always clear your plugins and re-download them by navigating to Help > Troubleshooting > Clear Support and Restart within Bridge.

    Select "Download Plugin." You'll then see the text "Downloading latest..." as well as a spinning wheel.


    When the plugin has finished downloading you'll notice a text box in the upper right-hand corner that says "Unreal Exporter Plugin Downloaded Successfully"


    You'll then need to set the Installation folder for the plugin to the Plugins folder within your Unreal Engine directory. By default, that directory is C:\Program Files\Epic Games\UE_4.24\Engine\Plugins 
    but this may be different if you've changed the install location of Unreal Engine on your machine.


    When the plugin has been successfully installed, you'll notice another text box in the upper right-hand corner that says "Plugin 6.3 Installed Successfully"


    Now we're going to launch Unreal Engine and create a New Project. The Project Settings of this project don't matter so don't worry about what they're set to. 
    ​​
    Because this is a new project, you'll notice there aren't any Megascans imported yet. 
    ​​
    So we'll need to go back to Bridge and import our surfaces to recreate our Blend Material
    ​​
    As before, select the three materials you wish to use for your blend and select "Create Material Blend" within the Plugin.
    ​​
    You'll now notice you have access to our new blend material - double click the instance to open and configure it however you need.
    ​​
    If you'd like to continue on in this New Project and work with the Blend Material then you can stop here. If you'd like to get the Blend Material working in other projects, please continue.

    With the Blend Material created, go to File > Save All
    ​​
    Once your SurfaceBlend_MasterMaterial has been created, it will be accessible within your Content Browser
    ​​
    Right-click the master material and go to Asset Actions > Migrate
    ​​
    You will be prompted with a hierarchy list in an Asset Report Window. Leave all the boxes selected and click OK.
    ​​
    You will be provided a Windows Explorer Window. Navigate to the Content folder of the project you wish to utilize the new Blend Material in.

    You will then be prompted with a Message window stating that a MasterMaterial_SurfaceBlend already exists, and Unreal will ask if you wish to overwrite it. Click "Yes All."


    You should see a window in the lower right-hand corner that says Content Migrated Successfully
    ​​
    You may now close your project and re-open the project we just migrated the MasterMaterial_SurfaceBlend.


    One last time, select the materials you wish to blend together and select "Create Material Blend" within the Plugin.
    ​​
    You will now have access to the new Material Blend within your existing project. 

    We apologize for this inconvenience and the need for this workaround. We are already working on a solution to this issue. Please note that this workaround is only required if you wish to use the new blend material in a previously existing scene that uses Megascans. If you wish to use our new Blend Material in a brand new scene, you'll simply need to update the plugin within Bridge and re-select your installation folder. 

    Thank you for your patience through this - we can't wait to see what you create with this new tool!

     

     

     

    Comment actions Permalink
  • Nanim3d

     I get the same problem.

    0
    Comment actions Permalink
  • Nanim3d

    Well, I did go to the menu  Help / Troubleshooting / Clear Support and Restart.

    After that go with the procedure as you are installing a plugin for the first time.

    1
    Comment actions Permalink
  • hoi

    Thanks Ian and Nanim3d for the advice. I end up deleting the megascans plugin in the unreal plugin folder. Re-install thru the bridge and now everything works like in the tutorial in Youtube. Thank you!

    0
    Comment actions Permalink
  • Zii

    Is there any workaround for getting this new feature to function in an already existing project? Removing it, clearing the plugin, and reinstalling did not make a difference. Would hate to migrate 200GB+ of assets into a new project just to have this working :(

    1
    Comment actions Permalink
  • JakeE

    This workaround worked for me, 4.24. Thanks!

    1
    Comment actions Permalink
  • Anuj

    Hello Ian,

     

    I actually tried doing this very solution before I came across this post. I thought I may be doing something wrong while trying this workaround, so I tried following the exact steps in this post. But after making a third new project, the Blend Material is still showing me the old settings.

    Engine version: 4.25.3

    Megascans Plugin version (as seen in Engine): 0.10

     

    I think what has happened is that when Quixel pushed the update, the Parent Material (SurfaceBlend_MasterMaterial) didn't get updated for quite a few people. Maybe, while you are working on a fix and pushing the update, could you please provide us with the updated version of this particular parent material? It may solve the issues that many of us are having.

     

    Thanks for your time and help,

    Anuj.

    0
    Comment actions Permalink
  • Ian

    Zii - The workaround posted above will enable you to utilize the new Blend Material in an existing project.

    Anuj - I noticed that you have also created a support ticket with our team. In the future please limit posts to one venue at a time to maximize our capability to help as many people as possible and prevent overlap. Thank you!

    1
    Comment actions Permalink
  • Zii

    Thank you Ian that did it for me! Good luck everyone.

    1
    Comment actions Permalink
  • Haitham Sweilem

    Thanks for the workaround. It worked for me UE 4.25.3

    1
    Comment actions Permalink
  • Clev
    Hello everyone,
    the problem I have is that the material does not appear
    in my mesh ``SM_Terreno''
    1
    Comment actions Permalink
  • Craig_Easton

    I deleted Bridge and reinstalled, and have started new a new Unreal project (4.25.3), but I still get the 'Fuzzy" function when I blend.

    I always have to re-setup the master material for the Megascan, but I don't get the latest material/blend.  Also, clicking in the order that the video suggests doesn't align the levels as per the video.

    Don't have to fix it just for me, but would love to get an email when it's been updated/fixed so I can start on it.

    0
    Comment actions Permalink
  • Craig_Easton

    Forget my previous query - I was making a mistake in installing the plugin and now have it working!!

     

    1
    Comment actions Permalink
  • JiYeon,Kong

    I had the same problem, but I solved it by watching this tutorial. Thank you.

    1
    Comment actions Permalink
  • srlake314

    I tried all the "solutions" and updates listed here, and I still have the same issue as the initial poster.  Everything is updated, etc.  Not sure why it's not working???
    I don't see the Global nor the multiple materials as the youtube video shows.

    0
    Comment actions Permalink
  • srlake314

    Now, the material isn't coming in or being built when I import them, all I'm getting are the textures and maps.  Very weird.

    0
    Comment actions Permalink
  • Ian

    srlake314 - I've created a support ticket for you so we can see what's going on with your project. You'll hear from our support team via email soon. Cheers!

    1
    Comment actions Permalink

Post is closed for comments.