Quixel Help Center home page

Import to UE4 shows meshes 100 times too big

Completed

Comments

6 comments

  • Jonathan (Community Manager)

    Hi JamesMoody - please read over our guide to creating a support request and add any pertinent information that can assist us with diagnosing what's happening in your situation. Videos and screenshots are encouraged as we're unable to resolve most issues without additional information.

    0
    Comment actions Permalink
  • JamesMoody

    Hi, I have thoroughly searched the forums, but the only similar scaling issue was someone who thought their imports were too small but it turned out they weren't. I have now added a screenshot of a roman statue (tgsibj3fa) that Quixel shows is in the 1-2 m scale range next to the mannequin - but it is 100 times larger, if that will help. Otherwise I have not changed any settings - it worked last time I tried it, but now everything is 100 times larger - even downloads that previously imported fine now import too large (they were already in my downloads) so I think it is purely in the export that is the issue. I can get around it by setting build scale in the mesh settings in UE4 to 0.01 for X, Y and Z, but its a bit annoying when it used to work.

     

     

    0
    Comment actions Permalink
  • Blllzo

    Hello,

    I am also currently experiencing the same problem and was wondering whether you had found a permanent solution?

    Kind regards,

    Blllzo

    0
    Comment actions Permalink
  • JamesMoody

    Hi, no, they asked for more details, which I replied to and since then I've heard nothing form them. My workaround is to import the static mesh and open in UE4 then go in the static mesh settings and change the scale permanently to 0.01 - but its not a real solution, just a workaround and really annoying.

    0
    Comment actions Permalink
  • MindThrower

    I found the reason why it's happening. If you previously imported some FBX and left an import scale at 100 and check the checkbox Convert scene - next exports from Quixel Bridge will be 100 times bigger. My solution is to import any FBX to unreal and during the import set the scale to 1. This will fix the scaling issue for Megascans export from Bridge.

    2
    Comment actions Permalink
  • Jonathan (Community Manager)

    Thanks for checking into this MindThrower! This thread unfortunately fell through the cracks - we try to avoid this when and where practicable.

    1
    Comment actions Permalink

Please sign in to leave a comment.