Quixel Help Center home page

"Enable Displacement" Not Working

Answered

Comments

9 comments

  • Official comment
    Ian

    Ddog, MrJaffaCake,

    Thank you for taking the time to post on our forum. We are aware of these issues and are working to provide an update to resolve these occurrences. In the meantime, please use the following workarounds - and rest assured that we're working to deploy solutions as soon as practicable.

    With regard to Roughness and Displacement, while the textures aren't automatically exported and slotted into the proper materials within UE4, they are downloaded so they can be placed into your material instances manually. 

    In order for the correct texture inputs and features from our latest material overhaul to be available within your material instances, the Parent material for your Surface imports will need to be manually changed to MS_DefaultMaterial or MS_DefaultMaterial (depending on preference). Currently, when importing Albedo, Normal, Roughness into UE4, the Parent Material selected is MS_DefaultMaterial_CP - our Channel Packing material.

    Comment actions Permalink
  • MrJaffaCake

    Experiencing the same exact issue.

    0
    Comment actions Permalink
  • Jonathan (Community Manager)

    Thanks for the report! One of my support staff will be with you as soon as practicable to assist.

    0
    Comment actions Permalink
  • ckugler108

    I am having the exact same issue as well. Have tried reinstalling bridge and deleting plugin and everything that goes with it. The only thing that works is under export settings you have to reset the surfaces to default. In default though that leaves you with no roughness. So i am not sure what is going on but i was able to replicate this several times. I even tried doing this setup without roughness and then turning roughness back on. So i guess you could import it twice if you really needed to. At any rate this is very buggy and you should be able to setup the surface export settings with whatever maps you like and not have it affect the ability to create the displacement. This really needs to get fixed!!

    0
    Comment actions Permalink
  • ckugler108

    Ian, I am not clear where you would change your parent material upon export. Or is that done after the parent material has loaded?

    0
    Comment actions Permalink
  • ckugler108

    Also why is roughness not a default anymore for any of the surfaces, assets etc etc...

    0
    Comment actions Permalink
  • David Kimball

    having the same problem and the resolution steps are not working

    0
    Comment actions Permalink
  • Jonathan (Community Manager)

    Please refrain from bumping old threads and creating new threads to report the same issue, David Kimball.

    0
    Comment actions Permalink
  • Talha Ahmad (Product Support Engineer)

    DdogMrJaffaCakeckugler108

    We have just pushed an update to Bridge and this issue has been fixed. Furthermore, an update to the plugin for UE4 has been deployed as well. This issue was occurring because of a small bug in the previous update. The roughness map was not checked by default in the Export settings and when the roughness map was manually enabled, Bridge read it as a channel packing texture, and as a result, it was sending the Channel Packing Master material for the Parent material in UE4. Therefore, even when the Displacement map was enabled in UE4 and Bridge, it was not working, because for incorporating displacement, the Parent material is Displacement_MasterMaterial, but due to a bug, it was sending MS_DefaultMaterial_CP (this is for channel packing).

    Nevertheless, this issue has been fixed in the latest update. Kindly follow the steps below to fix this issue:

    1. Close Unreal Engine, if already running. 

    2. Update Bridge to the latest version. (When you open/restart Bridge, you'll get the prompt asking you to update)

    3. Once updated, please go Edit>Manage Plugins and update the Unreal Engine plugin as well. (the latest plugin is v7.1)

    4. Now, open your project in Unreal Engine, and Enable the Displacement and Import Master Material Textures option from the MS plugin UI.


    5. Now, go to the Edit>Export Settings in Bridge. And make sure the Displacement map is checked for Surfaces. (as shown below)

    6. Export your asset. Now you should be able to send the displacement map, and Unreal Engine will incorporate the correct Parent material. 

    Should you need any further information please let us know!

    -2
    Comment actions Permalink

Post is closed for comments.