Quixel Help Center home page

Displacement material not working (UE 4.26.1) error X3018: invalid subscript 'Interps' and warning X3206: implicit truncation of vector type

Answered

Comments

18 comments

  • Jonathan (Community Manager)

    If this is related to DX 12, you're most likely running into driver issues. I've personally found that my 2080Ti doesn't function at all with 3D applications unless I'm using the December Studio driver release. The latest drivers have been unusable for the moment.

    0
    Comment actions Permalink
  • Nicolas

    For all the people that are having the same issue:

    I managed to find a fix in my situation after 7 hours:

    1. I deactivated the megascans plug-in.

    2. Cleaned the project of any MS material and asset (that also means the MSPresets folder, Megascans folder, MS-based Blend materials and anything else that is slightly related to MS content)

    3. Switched the project to dx12 (Vulkan, which was workign at first, was crashing/freezing my entire PC when compiling the MS mats for some reason, when opening a scene)

    4. Closed the project for a later restart.

    5. Erase the plugin from the Engine\Plugins folder of your UE4.26  installation (usually located in C:\program files\Epic Games\UE_4.26\Engine\Plugins)

    6. Reinstall the UE4 Plugin from the bridge (you may have to reselect your Plugins folder from step 5)

    7. Erased all the defaultXXX.ini files from the project's Config folder

    8. Deleted the Intermediate folder and the DerivedDataCache folder

    9. Copy clean config .ini files (content of a Content folder from a fresh project) into the Config folder

    10. Copy and overwrite the Saved/Config folder (including contents) from a fresh project

    11. Start the unreal project again

    12. Activate the MS Plugin (and restart when asked)

    13. Enable the displacement in the MS Pluginmenu (Green Button with the white M)

    14. Enter bridge and export and asset of your choice

    15. Enjoy a working ue project with quixel.

     

    I still dont know why this works but I assume that some project setting f***s something up that is necessary for the plug in to run. Sadly, I cant tell which setting that is but overwriting the projects settings back to default and reinstalling the plugin (all in the order described) solves the issue for me. Right now, I am running the project with standard settings but with dx12 as explicit target and forward shading enabled. Defered Shading is also working. (opening my scenes in Vulkan STILL hard-froze my entire PC, maybe that's worth investigating/fixing as there seems to be a compability issue)

    Maybe this helps someone in the future.

    All the best and take care.

    Nicolas

    0
    Comment actions Permalink
  • Matthew

    I am having the same issue as Nicolas, but even after following his advice and rolling back my driver I'm having no luck... Have also replicated this problem in a fresh project FWIW.

    I'm using an RTX3070, have tried latest studio drivers and each version back to December 2020 so suspect its not a driver issue...

    -Matthew

    0
    Comment actions Permalink
  • Talha

    Hi Matthew,

    I am creating a support ticket for this post as I am gonna need some additional information to troubleshoot the issue. You'll receive an email shortly!

    0
    Comment actions Permalink
  • Gwrath

    Same issue, running an RTX2080. Even making the most basic material instances of R, G and B with no displacement it throws this error. Basically Blend Materials are off the table until this is fixed? 

    0
    Comment actions Permalink
  • Andy_Melbourne

    Hi, I have the same issue. Is there a fix yet??

    0
    Comment actions Permalink
  • Nicolas

    As I have stated in another post, the Unreal Project setting that caused this is "Instanced Stereo" for VR. Turning this off, is a workaround. Unfortunatly this setting is pretty important. Sadly, my post was left unreplied. It would be nice to have a fix or at least a ticket! Jonathan (Community Manager) Talha

    0
    Comment actions Permalink
  • Andy_Melbourne

    Thank you for the work around Nicolas, I have tried it and it worked great. The only problem is that I'm working on a project that will be using VR so I need the "Instanced Stereo" on!  

     

     Jonathan (Community Manager) Talha is there another work around or a permanent solution to this problem? 

     

    Thanks  Andy

    0
    Comment actions Permalink
  • Talha

    Nicolas

    Thank you for your detailed analysis of the issue. I was able to reproduce the issue on my end. It appears that this issue occurs on VR projects only. The materials seem to incorporate fine if they are exported without displacement, however, if the Displacement checkbox is enabled, then the Parent Material (MS_DefaultMaterial_Displacement) throws the following errors:
    [SM5] /Engine/Generated/Material.ush(2496,2-39): warning X3206: implicit truncation of vector type
    [SM5] /Engine/Private/AnisotropyPassShader.usf(169,3-16): error X3018: invalid subscript 'Interps'

    Furthermore, I can also confirm that the issue disappears if we turn off the "Instanced Stereo" from Edit>Project Settings>Redendering> VR. 

    This information has been relayed to Engineering and hopefully, the issue shall be fixed as soon as practicable. We appreciate your patience in this matter. 

    Andy_Melbourne Gwrath Matthew

    0
    Comment actions Permalink
  • Gwrath

    Thanks for the update Talha, fingers crossed for a speedy solution :)

    0
    Comment actions Permalink
  • David Ferreira

     VR project working fine in 4.25, moved to 4.26, same problem.

    0
    Comment actions Permalink
  • Matthew

    Good to know it's been replicated and identified. I didn't mention it, but yes it is a VR project I am working on that produced this error.

    I look forward to a resolution, although this potentially sounds like an issue that needs addressing in Unreal Engine as well and I get the sense VR is a little overlooked by the dev team at the minute...

    0
    Comment actions Permalink
  • VR4Arch

    I just want to add that this happened to me while migrating level to "clean" project so I get rid of all unnecessery assets from the original one.

    I was not able to see the blend material applied in the second scene and it was reporting exact 2 messages TALHA mentioned few posts above.

    0
    Comment actions Permalink
  • Mizuhara

    Talha. Is there any workaround for this while we wait for an official fix? Or anyone else for that matter. We are using VR for all of our projects and this displacement just gives it a little oomf and boost. So far, faking normals with strategic lighting is the best I can do so far.

    0
    Comment actions Permalink
  • digicraft63

    Glad but sad to hear that others have this problem except for me on the entire planet.

    For several others including me turning on "Instanced Stereo" seem to causing the problem. Another problem with "Instanced Stereo" turned on is that EU 4.26 new water feature does not work. Works pretty fine with "Instanced Stereo" off except when going under water that crashes!

    I am using Pimax 5+ and GTX 1080 Ti and Pimax 8k and RTX 2080 on another computer. The only difference with "Instanced Stereo" set to off is drop of frame rate about 5-10 fps on my system. That is not a major issue for my VR project but it can of course be a major problem for others. So I hope this problem will be solved.

    0
    Comment actions Permalink
  • unmodify

    This is pretty easy to fix.  In 4.26.2  I edited 

    /Engine/Shaders/Private/AnisotropyPassShader.usf

    on mine, line# 167:  (replace the text, save, and start editor)

    #if INSTANCED_STEREO
    #if USING_TESSELLATION
    //Output.Interps.InterpolantsVSToPS.EyeIndex = EyeIndex;
    Output.FactoryInterpolants.InterpolantsVSToPS.EyeIndex = EyeIndex;
    #else

    Looks like someone just forgot to write a variable.  with the fix it compiles just fine.

    3
    Comment actions Permalink
  • digicraft63

    Haha!
    That did the trick UNIMODIFY. Thank you!

    0
    Comment actions Permalink
  • Mizuhara

    UNMODIFY, You are a god. No way in hell I could have figured that out. Thank you. Thank you.

    1
    Comment actions Permalink

Please sign in to leave a comment.