Quixel Help Center home page

Metal materials in UE4 look completely different to Mixer?

Completed

Comments

7 comments

  • Official comment
    Ian

    Hello Komsur,

    Thanks for reaching out on the forum. Please note that when using the provided Megascans master materials, such as MS_DefaultMaterial, the metallic maps are disabled by default. This is due to the fact that the vast majority of the Megascans library is dielectric, so the metallic map option within your material instance will need to be enabled and the map from Mixer will need to be placed manually. 

    Comment actions Permalink
  • Komsur

    Hi, thanks for getting in touch so quickly.

    So I believe I've already set this up, but I'm not 100% sure. I've exported a metalness map from Mixer and I've put it in UE4 and assigned it to the correct slot in the material, but it sounds like you're saying there's a bit more to it, I think.

    Attached is a picture of my material, you can see I've got an albedo, roughness, metalness and normal all plugged into the right places.

    Am I still missing something?

    Thanks for you help.

    0
    Comment actions Permalink
  • Ian

    Komsur,

    You're not technically missing anything. The setup that you're utilizing right now is the correct basis for creating materials in UE4! The main difference is likely due to the lighting between Mixer, which is using a specific HDRI, and Unreal Engine, which is using a different HDRI. You should also make sure that your imported textures are using the correct compression settings, such as "Masks" for Roughness and Metallic. You can do this by double-clicking the texture and using the drop-down menu under "Compression Settings." Remember to save before you close the window!

    Additionally, there are always ways to improve your materials in case they don't look exactly how you expected them to once you've imported them into UE4 that will also give you more control over each individual map. I'd like to recommend that you watch the Unreal Online Learning tutorial on creating PBR materials that I've linked here,

    https://www.unrealengine.com/en-US/onlinelearning-courses/creating-pbr-materials 

    0
    Comment actions Permalink
  • Komsur

    Hi,

    I had a feeling it might be to do with HDRI maps. Is there any way to get Mixer's HDRI map into UE4, or the other way around? I'd like the programs to look similar as it's not very helpful to have such a drastic change.

    0
    Comment actions Permalink
  • Ian

    Komsur,

    The lighting in UE4 is capable of reproducing almost any look, feel, or atmosphere. However, Mixer, in its current state, is not yet capable of having custom HDR images loaded or extracted. However, it is a feature that is being looked into for future releases.

    At this time, the prevalent workflow would be to choose a lighting option within Mixer that is most suitable to your end-goal lighting within Unreal engine, and then utilize the material parameters as listed above to dial in the look of your materials in engine. 

    0
    Comment actions Permalink
  • Komsur

    That's good to hear that it's a feature being looked into, I can certainly see it being useful.

    Otherwise, with you mentioning the HDRI maps, I had a look into it and found a workaround that was fairly fiddly, but did the job and the materials were looking pretty similar in both Mixer and Unreal, so that's solved my issues, thanks for your clearing up of my questions.

    1
    Comment actions Permalink
  • Ian

    Komsur,

    You're quite welcome. Please feel free to reach out again if we may be of further assistance!

    Cheers!

    0
    Comment actions Permalink

Post is closed for comments.