Quixel Help Center home page

Can't open Bridge in Unreal Engine 4.27

Answered

Comments

12 comments

  • Yasir Q

    Hello TonySchilling,

    Thank you for writing to us. I have converted this forum post to a support ticket so that we may work to further troubleshoot and resolve the issue you're experiencing. Please be on the lookout for an email from our support team shortly.

    1
    Comment actions Permalink
  • Napalm

    I'm having the exact same problem, was there a fix?

    1
    Comment actions Permalink
  • Yasir Q

    Hello Napalm,

    Thank you for reaching out. I've converted your post to a support ticket, we'll require more information to troubleshoot the issue you're experiencing. 

     

    0
    Comment actions Permalink
  • hello

    Same problem here.  We try everything to fix the bug re install mixer plugin from Bridge, delete & install UE4.27 nothing is working.  Any solution ?

    0
    Comment actions Permalink
  • Talha Ahmad (Product Support Engineer)

    Hello,

    This particular error occurs when there's a conflict between the installed Plugin Version and the Engine Version. In most cases, it's a user-specific error and occurs due to one of the following reasons: 

    1. Installed Plugin and Engine Version are mismatched

    Kindly launch Bridge and go to Edit>Export Settings, and make sure you have selected the correct Engine Version.

    2. Incorrect setup of Bridge's Local Library

    We have noticed that a lot of users reporting this issue usually make a mistake when they are setting up Bridge's Local Library. The library path is basically the path for your local Megascans library and all the assets and plugins are downloaded there. Some users wrongly write the plugin's installation path (<Epic Games>/UE_4.2x/Engine/Plugins) into the Library Path of Bridge.

    You can confirm this by going to Edit>Settings in Bridge. The path given in the Library Path field should be your local library path


    If this is the cause of the issue on your end, then please follow the steps below to fix the issue:

    >Go to Edit>Settings in Bridge and change the Library Path to a different location as shown in the image above. 

    >Go to <Epic Games>/UE_4.27/Engine/Plugins and you'll find a folder titled "support" in this directory. Delete this folder. (This folder got created when the Library Path was wrongly pointing to this directory and this particular folder is causing a conflict with the Engine Version because it contains the downloaded plugins for all the versions)

    >Go to Bridge, download & install the plugin again. 

    This should fix the issue. 

    3. Corrupt Plugin file

    Sometimes, this error could simply be there because the plugin file got corrupted due to some unknown reasons. In such cases, you can simply clean reinstall the plugin and the issue will be fixed. In order to perform the clean reinstallation of the plugin, please follow the steps below:

    >Removing the Plugin: https://help.quixel.com/hc/en-us/articles/360003342698-Removing-the-UE4-Plugin

    >Reinstalling the Plugin: https://help.quixel.com/hc/en-us/articles/360002127457-Installing-the-Megascans-Plugin-for-UE4-on-Windows 

    Note: For the Plugin Reinstallation, please follow the steps mentioned in the "Installation Via Export Settings" section in the link given above.

    2
    Comment actions Permalink
  • fACARUS

    Hello Talha Ahmad, I am usinng UE5 with has Bridge incorporated, but its Path Tracer is not working so have chosen to re-paint my project in UE4.27, I remember having Bridge before but has dissapeared, I am trying to install with external Bridge downloaded version, I choose my material, downlaod and try to export but it says I have to install pluggin. The pluggin has been installed with the comprehensive guide, chosen libray destination C:\Users\Usuario\Documents\Megascans Library and pluggin destination within C:\Program Files\Epic Games\UE_4.27\Engine\Plugins. Bridge recognizes the plugggin as installed when in export settings but downloading asks me to install. The engine has the megascan folder but the engine when running doesnt have the Bridge icon nor does it appear in the pluggins library, thank you for your help

    1
    Comment actions Permalink
  • Deedor

    Had the same issue as Facarus i.e. using correct paths but plugin is not in Unreal and can't export from Quixel Bridge. The problem is with the plugin install. It only partially installs. There's a YouTube video that shows how to manually unzip the plugin and overwrite the failed install. This fix works.

    0
    Comment actions Permalink
  • fACARUS

    Would be great Deedor if you could post the video link, thank in advance

     

    0
    Comment actions Permalink
  • Deedor

    Here you go. This has fixed the unreal plugin but sadly bridge still won't export metahumans to Unreal. Searching for multiple bug fixes now 😒

    https://www.youtube.com/watch?v=zsya1G5FDes

    0
    Comment actions Permalink
  • fACARUS

    Great Thanks

    Had Metahumans in Epic Launcher for a while, am creating the project, I let you know which engine it uses

    0
    Comment actions Permalink
  • Deedor

    Okay, last fix for me was to follow the steps in the YouTube video. Then set the Bridge plugin path to

    C:\Program Files\Epic Games\UE_4.27\Engine\Plugins\MegascansPlugin

    not

    C:\Program Files\Epic Games\UE_4.27\Engine\Plugins\

    Then click install. It then instantly recognises the installed plugin (rather than installing it again).

    BTW, the default project setting appears to be irrelevant and it creates the folders in the directory you have open (not the one specified).

     

    0
    Comment actions Permalink
  • Iconburger

    Why don't you update the instructions? Wasted time on same issue. A lot of people have been doing this AND will do it in the future. Just change add a bit of text.  Add a note and/or pop up - or any type of message that states: "DO NOT USE C:\Program Files\Epic Games\UE_4.27\Engine\Plugins", instead use: 

    C:\Program Files\Epic Games\UE_4.27\Engine\Plugins\MegascansPlugin

     

     

    1
    Comment actions Permalink

Please sign in to leave a comment.