Quixel Help Center home page

Textures looking glossy when importing to Blender 3.0 from Bridge

Answered

Comments

6 comments

  • Laila Shahzad

    Hello,

    Thank you for taking the time to reach out to us. Please note that Blender 3.0 is not currently supported by our plugin. For a complete list of supported DCCs please refer to our FAQ page.

    If there's anything else that I may assist you with, please don't hesitate to reach out. We're always happy to help!

    0
    Comment actions Permalink
  • mango

    Noticed this problem too today after updating to Blender 3.0, seems like material nodes get messed up when exporting to Blender, while we wait for an official fix, problem is solved when adjusting the nodes manually, or you can open a previous version of Blender to export from Quixel 

    1
    Comment actions Permalink
  • Artyom

    If you correct node setup by hands don't forget to turn off clearcoat

    2
    Comment actions Permalink
  • CartoonCaveman

    Thanks ARTYOM!! That works awesome with Blender 3.0...was driving me crazy

    0
    Comment actions Permalink
  • Madhav

    Set Clearcoat to 0 if you want to remove glassiness

    and set norma map correctly

     

    0
    Comment actions Permalink
  • GiffInteractive

    for anyone coming here later, there is a patched plugin here

    0
    Comment actions Permalink

Please sign in to leave a comment.