Quixel Help Center home page

Megascan plugin error message

Answered

Comments

2 comments

  • Laila Shahzad

    Hi,

    Thanks for posting! Blender 3.0 is currently not supported by our Plugin functionality: https://help.quixel.com/hc/en-us/articles/360002073717

    I sincerely apologize for the inconvenience this may cause and rest assured our devs are working hard to support all current versions of Engines/DCCs. We cannot at this time share any estimated dates, but once the Plugin is updated, it will be posted on the Forum.

    In the meanwhile, you may manually import our assets into Blender - please refer to the Blender manual on how to do so. Thanks for your patience and understanding!

    0
    Comment actions Permalink
  • BrunoSura

    Well, still works :) not perfect but works. I guess I will remove it to find out if that is making Blender crash. Thank you 

    0
    Comment actions Permalink

Please sign in to leave a comment.