Quixel Help Center home page

unable to reach epicgame - on login




  • Anna King


    I'm sorry to hear you're experiencing this issue, and I'm happy to help out with this. Please first check to make sure Mixer is not currently being blocked by your anti-virus or firewall.

    If you're still seeing the same error, please ensure that Mixer is not running by checking the task manager, then navigate to the following path: 
    C:\Users\<Username>\AppData\Roaming\Quixel\Quixel Mixer\

    Once you're within the Quixel Mixer folder, please delete the Settings folder. Then, please follow these steps.

    1. Go to your Program files folder and see if you have a previous version of Mixer installed.
    2. Open the Quixel Mixer folder, and uninstall the application using the uninstaller
    3. Then, navigate to the following path and delete the temp files folder: C:\Users\<username>\AppData\Local\Temp\Quixel Mixer
    4. Delete the Mixer installer from your system.
    5. Clear your cache and cookies on whichever web browser you are using.
    6. Once you've cleared your cache and cookies, re-download a new installer from quixel.com/mixer and reinstall Mixer.

    Please let me know how it goes, or if you have any questions! 

    Comment actions Permalink
  • Clausi

    I've followed every step you suggested, but it still doesn't work.
    I've tried uninstalling several times, but nothing changes.

    Comment actions Permalink
  • Anna King

    Thanks for the update, I appreciate it!

    I've converted your forum post into a ticket, as we will need to request log files moving forward. Please look for an email from us in your inbox! In the meantime, please check to ensure you are able to sign in on the Bridge application itself, as well as the Megascans website. We will be in touch shortly. 

    Comment actions Permalink

    Hi, i have the same problem. i installed the latest but the problem percist, same happened when I installed the previous version too. i could not reach to epicgames. what should I do? thanks

    Comment actions Permalink
  • Clausi

    For me it turned out to be a file that had been blocked by my firewall - the filename didnt suggest any connection to mixer, so if you have a firewall might be a good idea to check that. It is called ZFGameBrowser.exe

    Comment actions Permalink
  • Ultragravy3

    I have this problem too. I tried updating Quixel as well.

    Comment actions Permalink
  • Anna King

    Hey there, Ultragravy3, I'd be glad to help!

    If you are still experiencing this issue after a clean reinstall of Mixer, please try using a different internet connection of your choice as a test to see if the issue persists, and please let me know how that goes. 

    Additionally, have you been able to check for the file "ZFGameBrowser.exe"? If not, please check to see if this exists as a blocked program or not within your firewall settings. If you are able to locate this, please let me know. I'd be glad to investigate this further. 

    Comment actions Permalink
  • raidofuwa

    In my case, I could login after I deleted bunch of registry keys for old installation. If you have this issue maybe you can login in the same way. But be careful, everybody knows it's not good to mess around with registry keys because it cause problem.

    I think Microsoft people are crazy. Do they still think "registry" is a good idea? Anyway, you guys shouldn't use it for your software, IMHO. Because it cause environment specific problem unexpectedly for 2000% for sure.

    I also found the other issue by the way. When I tried to login with gmail, oauth screen said I'm accessing with unsafe browser or something so I couldn't login with my gmail account. After couple of trials, I gave up to login with gmail and tried Epic Game account. It worked, successfully. I think Quixel Mixer should launch system default browser when user choose gmail for login like Epic Game Launcher usually does.


    Comment actions Permalink
  • Gantengboyy

    same with me bro, please add login using google account

    Comment actions Permalink
  • Urooj(Product Support Engineer)

    Hi Ultragravy3, raidofuwa, Gantengboyy,
    Thanks for the report.

    I have gone through your report and have something to share with you. This "unable to reach epicgames" error shows up when a third party plugin that is required to run Mixer is being blocked by your system. I'm going to share a few steps below, kindly follow them and see how it goes at your end:


    Note: Please make sure Mixer is not running in the background

    1. Navigate to the following path:
      C:\Users\<username goes here>\AppData\Roaming\Quixel\Quixel Mixer\Settings
    2. Clear everything in the Settings folder
    3. In the search bar, type "Firewall & network"
    4. Select "Allow an app through firewall"
    5. In the new window, select "Change settings"
    6. You should now be able to access the disabled part of the window. From here, select "Allow another app"
    7. A small window will pop up. Select Browse to add the file here
    8. Now you need to navigate to the required file and select it.

      8.1: Navigate to the following path where you have Mixer installed:

           <Your Mixer installation path>\Quixel Mixer_Data\Plugins

      8.2: Select the ZFGameBrowser application file

      8.3: Select "Open"
    9. Now select "Add" to proceed
    10. Now the application has been added to the exception list of your firewall. Select "Okay" to save the changes.
    11. Now restart your system
    12. Launch Mixer(Preferably with right click>run as admin)
    13. Login and see how it goes at your end. 

    Looking forward to your response. If the issue persists, please let us know. 


    Comment actions Permalink

Please sign in to leave a comment.