Quixel Help Center home page

My Metahumans Won't Download in UE5 Bridge

Completed

Comments

15 comments

  • TonyC

    I have exactly the same problem. I also tried to download My MetaHuman in the standalone version of Bridge with no success.

    I can download MetaHuman Presets no problems.

     

    Thanks

    0
    Comment actions Permalink
  • Hello Baazar and TonyC,

    Thanks for taking the time to write in. We're currently experiencing an issue with Custom MetaHumans inside of Unreal Engine 5 Preview 2. Please note that we are aware of the issue and are working to ship a fix as soon as practicable. I apologize for any inconvenience that this may have caused!

    1
    Comment actions Permalink
  • lee332

    I have the same problem too....

    0
    Comment actions Permalink
  • Baazar

    For those who are experiencing this, my workaround was to copy the url link when you right click or click the 3 dots on the character. Paste that in a browser and you can download it manually as a zip. Then just copy that folder into your content folder in your project.

    2
    Comment actions Permalink
  • Kinetic

    my work around is to download them in the stand alone quixel bridge export to an empty project then copy the files from the UE4 project and drop in them in my UE5 project seems to work pretty good still takes forever 

    0
    Comment actions Permalink
  • MrZondyz

    It's been 4 months this needs to be fixed. Starting to doubt using unreal engine and start with unity

    2
    Comment actions Permalink
  • Robert S

    Hi there, 

    Unfortunately, I'm having this same problem with custom UE5 Metahumans not downloading in the current 5.0.3 UE5.

    Sometimes, the download gets further when I stop, then restart,  but it never completes.

    After the last Bridge update (was on 5.0.2) I was able to download a custom Metahuman, but now that I'm on 5.0.3 seeing the same exact problem.  

    Also, I'm assuming with these new UE5 Metahumans, the workaround to download in the standalone Bridge app is also no longer possible.

    Would love some help!

    Many thanks.

    1
    Comment actions Permalink
  • Warbringer24

    Hello, I'm having the same issue on 5.0.3, posting here just for the notification when the solution appears.

    0
    Comment actions Permalink
  • Nick Reiz

    Hi, same problem. Don't download any metahuman in UE 5.0.3 (included bridge).

    0
    Comment actions Permalink
  • Goldenchild

    Hi, same issue for me too.

    0
    Comment actions Permalink
  • Baazar

    For those that can actually download but finding you can't add the files to your project via the broken Quixel Bridge, you can access the locally downloaded files and manually copy them to your project. 

    0
    Comment actions Permalink
  • Goldenchild

    My download stoppes around 15%. From the presets ones.

    0
    Comment actions Permalink
  • Anna King

    Hey there everyone, thanks for your comments to keep us updated on this issue!

    Many users have found that opening the ports and addresses in this list has resolved this issue with downloading MetaHumans, in addition to following the networking troubleshooting steps in this guide. The last step in the network troubleshooting guide mentions running Bridge/Mixer as administrator, however in the case of UE5, please try running the Engine itself as admin instead. To do this, please check your user account on whichever OS you are using to confirm your account has administrator privileges. 

    If the issue persists past those steps, please feel free to let me know, and we can create a ticket to look into the issue further for you. 

    0
    Comment actions Permalink
  • Seraphydai

    Hey guys, I  encountered the same problem here and tried a lot of methods and none worked,  then I found this page and thanks to you @ANNA KING your troubleshooting guides enlightened me, and some simple steps I seemed solved it, here's it ( I use Windows 11 Profesional): 

    1.Open "Firewall&Network Protection" pannel in Windows Setting;

    2.choose "advanced settings" to open the Advanced Security of WIndows Defender Firewall panel( I don't know for sure if this is the right name coz I'm using a non-English system);

    3. In the" Inbound Port Rules" page, double click each of  "EpicGamesLauncher" rule item, and choose "Allow connection" in the pop-out window;

    4. Double click each of  "EpicWebHelper" rule item, and choose "Allow connection" in the pop-out window;

    and voila, it just solved my problem, and I successfully downloaded my metahuman(1.25GB) in about 5-10 minutes, even after a couple of connection failures with a poor cellphone hotspot wifi.

    Hope this will help you.

    2
    Comment actions Permalink
  • Anna King

    I'm glad the steps helped, Seraphydai! Also, thank you for sharing details on how you resolved this for Windows 11, very awesome of you to do so! :) 

     

    0
    Comment actions Permalink

Please sign in to leave a comment.