Quixel Help Center home page

Insanely laggy ui in bridge for UE5

Answered

Comments

7 comments

  • Hello fritzwilliams,

    Thanks for taking the time to reach out to us. I'd be happy to look into this for you. To first troubleshoot the issue, would you please let me know if you're experiencing issues with any other functionality inside of UE5, or is this lag limited to Quixel Bridge?

    Please ensure that your GPU drivers are up to date with the latest versions (I recommend Studio drivers if you're using NVidia). Please also verify that you're on the full release version of Unreal Engine 5 and not on one of the Preview Builds. 

    I look forward to hearing from you!

    0
    Comment actions Permalink
  • fritzwilliams

    Thanks for the quick reply! I have noticed a slight decrease in my ue5 performance, but mostly it has just been bridge. My studio drivers are fully updated and I'm using version 5.0.0 of unreal. 

    0
    Comment actions Permalink
  • fritzwilliams

    I have tried deleting the app data as I saw in another post, and have also uninstalled and reinstalled the engine but haven't seen any improvement.

    0
    Comment actions Permalink
  • fritzwilliams,

    Thank you for taking the time to get back to me. I appreciate the additional information. I would be happy to bring this to the attention of our developers. If it's not too troubling, would you kindly provide a screen recording of the issue? Please upload any recordings to either YouTube or Streamable.com and then paste the link along with your response.

    I look forward to hearing from you!

    0
    Comment actions Permalink
  • fritzwilliams

    Thanks so much for the help. I found this morning that when I disconnected my other display the program became much more responsive. I was trying to capture screen recordings but with multiple monitors the system seemed to be glitching out so I disconnected my secondary display and suddenly bridge ran much faster. Not sure if this is a bug or if the program is just not meant to be run on a separate display but thought it was worth noting. I couldn't find a good way to record the laggy software because it kept clipping between the two monitors but it looks almost identical to the video in this post. https://help.quixel.com/hc/en-us/community/posts/360016078438-UE5-Bridge-extremely-poor-UI-performance

     

    0
    Comment actions Permalink
  • fritzwilliams,

    Thank you! That's very good information. As I am currently using a single ultrawide monitor, I haven't been able to reproduce the issue. Now that we are aware that multiple monitors may have an impact on Bridge's performance, that gives us another aspect to test. Much appreciated!

    I will bring this to the attention of our developers. I apologize that I can't provide a simple resolution for you at the moment, however, if there's anything else that I may be able to assist you with, please don't hesitate to let me know!

    0
    Comment actions Permalink
  • TylerFoo

    I'm also having this problem with a dual-monitor setup. Also i should mention that I'm on Linux. And I'm using the pre-compiled version from here: https://www.unrealengine.com/en-US/linux 

    0
    Comment actions Permalink

Please sign in to leave a comment.