Quixel Help Center home page

M_MS_Surface Material reimport

Answered

Comments

2 comments

  • ndaniels

    I think I have done the same thing :(( was following a tutorial and must have accidentally saved?? All my quixel materials are black now and i dont know how to reset it aah

    0
    Comment actions Permalink
  • Hasnat Arshad

    Hello, 

    Thank you for reaching out to Quixel Support! 

    When MS assets are imported from Bridge to Unreal Engine via the MS plugin, they inherit their material setup from a Parent material. We have unique Parent Materials (material setups) for every type of asset. They are our in-house designs which we have carefully tailored to meet the necessary requirements of the appearance of their relevant assets. We call these material setups Master Materials. They are a default stock of our UE plugin and are imported alongside every MS asset.

    Once, the above-stated default Master Material arrives, any FURTHER imports (that utilize the same Parent Material) do not bring in a new Parent Material. In case, that Parent Material already exists in the project (from a prior import), then the MS Plugin just imports the asset contents and utilizes the already existing Material files to generate the Material Setup. This is the main reason why each of you are facing errors on multiple imports. 

    The way to properly make changes to a master material,
    >> Disable the MSPlugin. 
    >> Then perform the edits to the existing Master Materials. (with the MS Plugin disabled... the changes won't get applied to the source directory)
    >> Once changes have been made, rename the existing Master Materials upon which you have made the changes. (this would ensure to bring in fresh copies of Master Materials upon a new asset import rather than utilizing the existing ones).

    Following are the workarounds with respect to Engine versions: 

    1) For UE versions up to 4.27 

    Ensure that Bridge and UE are not running.  

    Now, navigate to the following path in your Megascans Library

    ....Megascans Library\support\plugins\unreal\7.6\latest\win\4.27\MegascansPlugin\Content 

    Here you will find a folder titled "MSPresets". Go ahead and Copy this folder. 

    - Navigate to the Content folder in your project directory (....Unreal Projects\MyProject 4.27\Content) 

    Replace the present "MSPresets" folder with the one you copied. 

    - Now run Unreal Engine as an administrator and open up the project. 

    Once it opens, export an asset via Bridge and your issue will be fixed. 

    2) For UE versions 5.0 and onwards 

    - Ensure that UE5 is not running.

    - Launch the Epic Games Launcher and navigate to your UE Library tab.

    - Under Installed Plugins of UE5 please make sure that Bridge is updated to the latest version. 

    - Now, navigate to the following path in your UE5 Installation Directory

    ...UE\UE_5.0\Engine\Plugins\Bridge\Content

    Here you will find a folder titled "MSPresets". Go ahead and Copy this folder. 

    - Navigate to the Content folder in your project directory (....Unreal Projects\MyProject\Content) 

    Replace the present "MSPresets" folder with the one you copied. 

    - Now run Unreal Engine as an administrator and open up the project. 

    Once it opens, export an asset via Bridge and your issue will be fixed. 

     

    If the issue persists, please let us know and we will troubleshoot further. 

    0
    Comment actions Permalink

Please sign in to leave a comment.