Quixel Help Center home page

Custom Socket Exporter Mesh List is Incomplete

Answered

Comments

5 comments

  • Hi again,

    Can you please share what your export target is?

    For offline renderers, the custom socket exporter only exports a single LOD for every export. Bridge will only export the LOD with the highest tris. In your case, it's LOD0. However, if you want to export other LODs as well, then you can simply unselect LOD0 and export again, this will enable you to export LOD1. You can repeat this process by unselecting the subsequent LODs to achieve desired results. 

    The "Export all LODs for 3D plants" functionality is currently only supported for Unreal Engine. 

    0
    Comment actions Permalink
  • chrisperrella

    I am certain this is a regression/bug for 5 reasons. 

    1. I had code that worked less than 3 months ago that isolated the mesh in the second index asset['MeshList'][1] - that now fails with a IndexError.

    2. The emitted JSON data is a of a type() list - therefor its expecting a list programmatically - not a string which would equate to the path of one LOD.

    3. The custom socket exporter is not meant for offline renderers - its meant for automated pipelines that run a localhost server that receives the emitted JSON data, and manually exporting individual LODs makes no sense for any automated pipeline.  This would prevent users from doing even the most simple of an LOD packing command in python or c. 

    4. The UI supports multiselect. 

    5. Your own code on github expects it to be a list:

    #Get and store the geometry in the geo_list.
      foriteminjData['meshList']:
      if'path'initem:
      geo_list.append(item['path'])

    So, this is most assuredly a bug. 

    Can you please share what your export target is?

    Im using a Python Plugin based on your own Bridge exporter here https://github.com/Quixel/Bridge-Python-Plugin.  

    0
    Comment actions Permalink
  • chrisperrella

    This was also not answered.

    0
    Comment actions Permalink
  • Jonathan (Community Manager)

    Sorry about the wait here, Chris. We'll get back with you very shortly.

    1
    Comment actions Permalink
  • chrisperrella

    Apologies for the delayed response. Thank you for clarification on the issue. I am creating a zendesk ticket for this as well. We will be investigating this further and hopefully, a fix will be deployed as soon as practicable. 

    0
    Comment actions Permalink

Please sign in to leave a comment.